. : : ClassiClub ForuM : : .

会员中心 论坛帮助 日历事件 标记论坛已读
返回   精品技术论坛 » 技术论坛 » 『软件使用』

『软件使用』: 电脑软件推荐, 电脑软件使用, 经验分享



发表新主题 回复
 
主题工具
jotis
 
jotis 的头像
支柱会员
 
资 料:
注册日期: Jun 2002
帖子: 5,274 声望值: 3
精华: 0,解答: 12
#1 旧 2021-06-09, 09:36:50 默认 【求助】win10不支持gpt了?
jotis 当前离线  

我奇怪了,装系统说不支持gpt分区
我以前的怎么记得都是gpt分区装的啊
然后新建分区报错0xf947b2a0
奇怪了
有啥软件分区可以自动分出额外分区的?msr esp这些
dg快速分区好像要系统里没有现存分区才能分出这些
不知道是不是bios没设置uefi启动的原因,但是设置了uefi
安装u盘不能启动了 pe也启动不了 有人遇到过吗?

此帖于 2021-06-09 10:02:09 被 jotis 编辑. .


闭关中
回复时引用此帖
haonan
 
haonan 的头像
支柱会员
 
资 料:
注册日期: Feb 2004
帖子: 8,009 声望值: 4
精华: 1,解答: 19
#2 旧 2021-06-09, 10:26:14 默认
haonan 当前离线  

说明你的pe不是uefi启动的,所以只能安装到mbr分区。
下一个支持uefi的pe启动就可以安装到gpt分区。
或者直接把win10镜像写入U盘也可以uefi启动的。
回复时引用此帖
tacoal
 
tacoal 的头像
终极会员
 
资 料:
注册日期: Aug 2000
帖子: 10,396 声望值: 3
精华: 0,解答: 30
#3 旧 2021-06-09, 14:12:01 默认
tacoal 当前离线  

2楼说得是一种可能。

另外很多BIOS同时支持legacy和UEFI,可能你启动时选择的legacy方式启动pe,这时pe会认为系统不支持UEFI,就出现你遇到的情况
解决办法是启动时选择"UEFI .... USB ..."的选项,或者进到BIOS里面,把启动方式改为UEFI
当然,还有一种情况就是BIOS太老,不支持UEFI--现在非常少见。
回复时引用此帖
bestdoctor
 
bestdoctor 的头像
终极会员
 
资 料:
注册日期: Jul 2002
帖子: 18,524 声望值: 6
精华: 5,解答: 43
#4 旧 2021-06-09, 14:46:40 默认
bestdoctor 当前离线  

应该是楼主的硬件平台比较老,而用的win10安装版本又比较新

有两个解决办法
1,换老版本Win10,安装完毕之后再升级
2,用Winpe启动机器后,用安装器选择install文件安装

当然,前提是你的硬盘必须为GPT格式。最好预先用diskgeniuty分出EFI等分区
以上功能都可以用DG这个软件实现


E3 1230+2600+3570K+3770k+8550u+1065G7+8500B+8809G=34核
回复时引用此帖
jotis
 
jotis 的头像
支柱会员
 
资 料:
注册日期: Jun 2002
帖子: 5,274 声望值: 3
精华: 0,解答: 12
#5 旧 2021-06-09, 15:20:27 默认
jotis 当前离线  

引用:
作者: bestdoctor 查看帖子
应该是楼主的硬件平台比较老,而用的win10安装版本又比较新

有两个解决办法
1,换老版本Win10,安装完毕之后再升级
2,用Winpe启动机器后,用安装器选择install文件安装

当然,前提是你的硬盘必须为GPT格式。最好预先用diskgeniuty分出EFI等分区
以上功能都可以用DG这个软件实现
嗯,win10最新的21H1,后来预先分好EFI MSR了,进Win10还是报不能安装
18年的联想垃圾BIOS,查了是有一些BIOS出这个问题,选了UEFI启动,但是不能引导启动U盘,要调哪些设置,但我这个机器BIOS里没有CSM的打开项目,我后来又把GPT转回MBR装了,准备升级BIOS后再说,结果装完系统,升级驱动升级BIOS把机器直接升挂了,用序列号查官网,居然BIOS还分啥SKL平台KBL平台,他们自己平台都分不清吗?原来用Lenovo Vantage自己搜索驱动和BIOS自己升的
回复时引用此帖
bestdoctor
 
bestdoctor 的头像
终极会员
 
资 料:
注册日期: Jul 2002
帖子: 18,524 声望值: 6
精华: 5,解答: 43
#6 旧 2021-06-10, 20:47:07 默认
bestdoctor 当前离线  

引用:
作者: jotis 查看帖子
嗯,win10最新的21H1,后来预先分好EFI MSR了,进Win10还是报不能安装
18年的联想垃圾BIOS,查了是有一些BIOS出这个问题,选了UEFI启动,但是不能引导启动U盘,要调哪些设置,但我这个机器BIOS里没有CSM的打开项目,我后来又把GPT转回MBR装了,准备升级BIOS后再说,结果装完系统,升级驱......
很多PE里面自带了安装器
你预先改为GPT磁盘,然后把EFI分区和MSR分区用DG软件分好之后,安装器解决一切麻烦。完毕之后跟全新安装毫无区别

我感觉这种EFI的方式对多分区多系统非常友好,如果你仅仅是单win系统,其实没太大区别
回复时引用此帖
dog_come
 
dog_come 的头像
热心会员
 
资 料:
注册日期: Jan 2002
帖子: 17,948 声望值: 5
精华: 2,解答: 17
#7 旧 2021-06-10, 21:40:24 默认
dog_come 当前离线  

前两天给一部X201装WIN7想用UEFI,装完了不能启动,不研究,用回MBR


迷一样的厨神
回复时引用此帖
喜之狼
 
喜之狼 的头像
终极会员
 
资 料:
注册日期: Jan 2002
帖子: 15,046 声望值: 4
精华: 3,解答: 25
#8 旧 2021-06-11, 10:22:09 默认
喜之狼 当前离线  

很不喜欢EFI分区,无奈联想的新电脑都只有UEFI启动了


除了猪,谁还快乐的活着……
回复时引用此帖
billwei
 
billwei 的头像
核心会员
 
资 料:
注册日期: Jan 2002
帖子: 2,155 声望值: 3
精华: 0,解答: 5
#9 旧 2021-06-11, 11:01:05 默认
billwei 当前离线  

好像必须用微软官方工具制作的U盘启动安装才没问题。如果你用ISO工具比如ULTRAISO把微软的ISO制作成U盘启动就不行。

此帖于 2021-06-11 11:06:17 被 billwei 编辑. .
回复时引用此帖
MacOS
 
MacOS 的头像
热心会员
 
资 料:
注册日期: Aug 2002
帖子: 13,398 声望值: 5
精华: 0,解答: 129
#10 旧 2021-06-11, 12:33:53 默认
MacOS 当前离线  

联想在过渡期的机器有5楼问题,但18年的应该早解决了
设定里,把最后推荐配置打开,就会强制UEFI,你用任何UEFI启动盘就能安装到GPT中


HIDDEN MESSAGE LEVEL 3
14863 159357 789 159357 3245687 3684
回复时引用此帖
jotis
 
jotis 的头像
支柱会员
 
资 料:
注册日期: Jun 2002
帖子: 5,274 声望值: 3
精华: 0,解答: 12
#11 旧 2021-06-15, 15:01:08 默认
jotis 当前离线  

现在分区互转还要额外的空间的啊?
上传的图像
文件类型: jpg zhuanguid.jpg (29.0 KB, 24 次查看)
回复时引用此帖
发表新主题 回复

主题工具

论坛规则  发帖规则
不可以发表主题
不可以回复帖子
不可以上传附件
不可以编辑自己的帖子
论坛启用 vB 代码
版面启用 表情符号
版面启用 [IMG] 代码
版面禁用 HTML 代码


所有时间均为北京时间, 现在的时间是 04:14:16.

本论坛带宽由迅通网络提供
SSL证书由TrustAsia提供

Copyright © 2000 - 2019 ClassiClub Forum All Rights Reserved.
粤ICP备09123456号