. : : ClassiClub ForuM : : .

会员中心 论坛帮助 日历事件 标记论坛已读
返回   精品技术论坛 » 技术论坛 » 『软件使用』

『软件使用』: 电脑软件推荐, 电脑软件使用, 经验分享



发表新主题 回复
 
主题工具
aspirer
 
aspirer 的头像
支柱会员
 
资 料:
注册日期: Feb 2011
帖子: 4,899 声望值: 4
精华: 1,解答: 22
#1 旧 2020-09-06, 09:26:35 默认 已解答: 【求助】电脑自动登录2个QQ
aspirer 当前离线  

记得以前可以在快捷方式上做手脚,通过用将密码加密串附加到快捷方式参数里面


后来版本更新,好像这招不灵了

现在还有什么办法 让QQ记住密码(即免输密码,无人工干预的方法) 在开机后自动登录2个QQ账号吗?


朋友,你好……
回复时引用此帖
最佳解答为:
30900688
 
30900688 的头像
核心会员
 
资 料:
注册日期: Nov 2002
帖子: 3,153 声望值: 5
精华: 0,解答: 4
#2 旧 2020-09-07, 00:14:35 默认
30900688 当前在线  

装两个软件QQ、TIM试试,各自用不同的QQ号登录。
回复时引用此帖
sean500
 
sean500 的头像
热心会员
 
资 料:
注册日期: Sep 2001
帖子: 6,406 声望值: 4
精华: 0,解答: 24
#3 旧 2020-09-10, 11:42:35 默认
sean500 当前离线  

同楼上的思路:在不同的目录中,存放两个绿色版QQ,登录不同的QQ号,加入开机自动启动序列中。


Have a Nice Day!
回复时引用此帖
aspirer
 
aspirer 的头像
支柱会员
 
资 料:
注册日期: Feb 2011
帖子: 4,899 声望值: 4
精华: 1,解答: 22
#4 旧 2020-09-13, 08:35:43 默认
aspirer 当前离线  

引用:
作者: sean500 查看帖子
同楼上的思路:在不同的目录中,存放两个绿色版QQ,登录不同的QQ号,加入开机自动启动序列中。
这个经测试,不行。
回复时引用此帖
hnlyzhd
 
hnlyzhd 的头像
热心会员
 
资 料:
注册日期: Dec 2006
帖子: 6,062 声望值: 4
精华: 5,解答: 93
#5 旧 2020-09-13, 09:01:14 默认
hnlyzhd 当前离线  

QQ是支持记住多个账号及密码的,但只是不支持多账号自动登录,所以,可以写一个AHK、按键精灵之类的脚本,在启动QQ后,让它自动帮你按一下那个登录按钮。
回复时引用此帖
30900688
 
30900688 的头像
核心会员
 
资 料:
注册日期: Nov 2002
帖子: 3,153 声望值: 5
精华: 0,解答: 4
#6 旧 2020-09-15, 20:10:10 默认
30900688 当前在线  

实在不行的话,装个虚拟机。其中一个QQ放在虚拟机。
回复时引用此帖
月光光
 
月光光 的头像
超级会员
 
资 料:
注册日期: Apr 2002
帖子: 1,032 声望值: 2
精华: 0,解答: 4
#7 旧 2020-09-17, 09:46:23 默认
月光光 当前在线  

QQ是用特定的配置文件来配置自动登录的QQ号的,如果能准备两个不同号码自动登录的配置文件,再写个批处理,第一次运行QQ,可以自动登录第一个号码,然后把配置文件换成第二个个号码的,再次运行QQ就可以自动登录第二个号码了。
回复时引用此帖
月光光
 
月光光 的头像
超级会员
 
资 料:
注册日期: Apr 2002
帖子: 1,032 声望值: 2
精华: 0,解答: 4
#8 旧 2020-09-17, 09:50:55 默认
月光光 当前在线  

引用:
作者: sean500 查看帖子
同楼上的思路:在不同的目录中,存放两个绿色版QQ,登录不同的QQ号,加入开机自动启动序列中。
QQ是用特定的配置文件来配置自动登录的QQ号的,所以无论你在电脑里装多少个QQ,都是指向同一个配置文件,所以这方法行不通。
回复时引用此帖
aspirer
 
aspirer 的头像
支柱会员
 
资 料:
注册日期: Feb 2011
帖子: 4,899 声望值: 4
精华: 1,解答: 22
#9 旧 2020-10-04, 00:06:20 默认
aspirer 当前离线  

本想使用AutoIT的。后来发现它不好取得那个编辑框的句柄。
没太考虑按键精灵,一是好久没用了。二是觉得录制的脚本会受限于当时的情况(QQ窗体位置等等)。而且QQ登录的号码列表顺序会发生变化。

后来决定用手上正好有的开发工具易语言(也是不久前刚学的,为了开发股票插件. )趁国庆弄了下。这个QQ窗体有个问题是用类名来取句柄的话,登录前和登录后都取到。所以额外对窗体的宽度做了核对。

原理就是 启动QQ程序,模拟移动鼠标到号码输入框,模拟输入第一个要登录的QQ号码,模拟回车
接着再来第2个号码。

成品的EXE就先不放了。我加上销毁程序自己的代码后,编译生成,火绒居然就报病毒了。奇葩。
放上主要代码吧。

代码:
.版本 2

QQ路径 = 读配置项 (取运行目录 () + “\setting.ini”, “配置”, “QQ路径”, “D:\Program Files (x86)\Tencent\QQ\Bin\QQScLauncher.exe”)
QQ号码 = 读配置项 (取运行目录 () + “\setting.ini”, “配置”, “QQ号码”, “”)
QQ号码数组 = 分割文本 (QQ号码, “|”, )


.计次循环首 (取数组成员数 (QQ号码数组), n)

    运行 (QQ路径, 假, )
    延时 (3000)

    窗口_模糊遍历窗口 (, “TXGuiFoundation”, “QQ”, QQ窗口句柄)
    窗口数目 = 取数组成员数 (QQ窗口句柄)

    .如果真 (窗口数目 ≠ 0)
        .计次循环首 (窗口数目, i)
            输出调试文本 (i)
            QQ窗体位置 = 窗口_取位置和大小 (QQ窗口句柄 [i])
            .如果真 (QQ窗体位置.宽度 = 495)
                输出调试文本 (“发现QQ登录框”, QQ窗体位置.宽度, QQ窗体位置.高度)
                鼠标_带轨迹移动 (QQ窗体位置.左边, QQ窗体位置.顶边, QQ窗体位置.左边 + 235, QQ窗体位置.顶边 + 275, 4)
                鼠标_按键 ()
                延时 (500)
                键盘_模拟输入 (QQ号码数组 [n])
                延时 (500)
                键盘_模拟输入 (字符 (13))
            .如果真结束

        .计次循环尾 ()
    .如果真结束

    延时 (10000)

.计次循环尾 ()

.如果真 (进程_取同名ID (“QQ.exe”) = 取数组成员数 (QQ号码数组))
    ' 都登录完了,退出自己吧
    销毁 ()
.如果真结束

此帖于 2020-10-04 00:10:01 被 aspirer 编辑. .
回复时引用此帖
繁体
 
繁体 的头像
核心会员
 
资 料:
注册日期: Oct 2002
帖子: 2,411 声望值: 3
精华: 0,解答: 17
#10 旧 2020-10-04, 19:32:24 默认
繁体 当前离线  

引用:
作者: 30900688 查看帖子
装两个软件QQ、TIM试试,各自用不同的QQ号登录。
QQ和TIM都有绿色版本的(或者是安装也一样),各自自动登陆某个号码,加到启动里。
如果要求是登陆2个号码,这个办法应该是要求最低的,也是最省心的,电脑盲也可实现。


2008年9月19日,
回复时引用此帖
发表新主题 回复

主题工具

论坛规则  发帖规则
不可以发表主题
不可以回复帖子
不可以上传附件
不可以编辑自己的帖子
论坛启用 vB 代码
版面启用 表情符号
版面启用 [IMG] 代码
版面禁用 HTML 代码


所有时间均为北京时间, 现在的时间是 23:50:43.

本论坛带宽由迅通网络提供
SSL证书由TrustAsia提供

Copyright © 2000 - 2019 ClassiClub Forum All Rights Reserved.
粤ICP备09123456号