. : : ClassiClub ForuM : : .

会员中心 论坛帮助 日历事件 标记论坛已读
返回   精品技术论坛 » 技术论坛 » 『软件使用』

『软件使用』: 电脑软件推荐, 电脑软件使用, 经验分享



发表新主题 回复
 
主题工具
midi
 
midi 的头像
超级会员
 
资 料:
注册日期: Oct 2001
帖子: 1,125 声望值: 3
精华: 5,解答: 35
#61 旧 2014-12-16, 10:16:41 默认
midi 当前离线  

引用:
作者: savage 查看帖子
请问下LZ是怎么打包成exe的,谢谢
我用的是cx_Freeze。这里有介绍:
hxxp://cx-freeze.readthedocs.org/en/latest/overview.html

另外谢谢58楼和59楼的支持 回头准备再更新一次。。。
回复时引用此帖
midi
 
midi 的头像
超级会员
 
资 料:
注册日期: Oct 2001
帖子: 1,125 声望值: 3
精华: 5,解答: 35
#62 旧 2015-01-07, 11:23:26 默认
midi 当前离线  

已更新,算是兑现“承诺”了
回复时引用此帖
hnlyzhd
 
hnlyzhd 的头像
热心会员
 
资 料:
注册日期: Dec 2006
帖子: 6,480 声望值: 4
精华: 5,解答: 103
#63 旧 2015-07-22, 08:38:21 默认
hnlyzhd 当前离线  

@midi 为什么我运行的时候总是出现这个错误:

jpg_tool_error.png


我装了Python,也安装了楼主提供的那个ImageMagick,只不过我的不是在C:\Program Files(x86)目录下,而就是在C:\Program Files目录下,环境变量也设置了。不过我的Python 2.7.10是在这个软件之后安装的。因为我原来安装的是Python 3.4。
回复时引用此帖
midi
 
midi 的头像
超级会员
 
资 料:
注册日期: Oct 2001
帖子: 1,125 声望值: 3
精华: 5,解答: 35
#64 旧 2015-07-24, 19:16:48 默认
midi 当前离线  

引用:
作者: hnlyzhd 查看帖子
midi 为什么我运行的时候总是出现这个错误:我装了Python,也安装了楼主提供的那个ImageMagick,只不过我的不是在C:\Program Files(x86)目录下,而就是在C:\Program Files目录下,环境变量也设置了。不过我的Python 2.7......
这个找不到库的原因,最后发现是安装了多个ImageMagick库。解决办法就是除了32位的库以外,其他都卸载。Python其实不需要单独安装。

在英文系统中,还可能报下面的错误:
cannot get zipimporter instance.png
这是由于打包的工具(cx_freeze)不支持中文路径所致。目前的解决办法是重新打包成英文的exe文件 (如果有朋友需要再上传):blush;
回复时引用此帖
cefiro2
 
cefiro2 的头像
超级会员
 
资 料:
注册日期: Feb 2002
帖子: 1,336 声望值: 3
精华: 0
#65 旧 2015-11-04, 12:09:11 默认
cefiro2 当前离线  

相当好用,感谢楼主!


網路過客,來也匆匆,去也匆匆...轉眼間...
回复时引用此帖
midi
 
midi 的头像
超级会员
 
资 料:
注册日期: Oct 2001
帖子: 1,125 声望值: 3
精华: 5,解答: 35
#66 旧 2016-01-02, 12:19:18 默认
midi 当前离线  

刚刚更新到0.90版本,算是问候大家新年快乐吧

此帖于 2016-01-04 01:03:01 被 midi 编辑. .
回复时引用此帖
simp
 
simp 的头像
热心会员
 
资 料:
注册日期: Aug 2000
帖子: 723 声望值: 4
精华: 0
#67 旧 2016-01-03, 09:53:33 默认
simp 当前离线  

保持分辨率不变,体积变小,不错[emoji4]


从我的 iPhone 发送,使用 Tapatalk
回复时引用此帖
无痴
 
无痴 的头像
热心会员
 
资 料:
注册日期: Apr 2006
帖子: 1,062 声望值: 5
精华: 0,解答: 1
#68 旧 2016-01-03, 20:07:28 默认
无痴 当前离线  

感谢,lz新年快乐。


海阔凭鱼跃,天高任鸟飞!
回复时引用此帖
towall
 
towall 的头像
中级会员
 
资 料:
注册日期: Sep 2001
帖子: 424 声望值: 3
精华: 1,解答: 1
#69 旧 2016-01-05, 11:37:50 默认
towall 当前离线  

引用:
作者: midi 查看帖子
刚刚更新到0.90版本,算是问候大家新年快乐吧
百度盘里没有找到您的这个工具啊。在哪个目录里?
回复时引用此帖
midi
 
midi 的头像
超级会员
 
资 料:
注册日期: Oct 2001
帖子: 1,125 声望值: 3
精华: 5,解答: 35
#70 旧 2016-01-05, 12:48:53 默认
midi 当前离线  

引用:
作者: towall 查看帖子
百度盘里没有找到您的这个工具啊。在哪个目录里?
我被吓到了,还以为真的没了 到这里找:
path.png
没看到,可能是因为文件夹出现在最下方的缘故。
回复时引用此帖
无痴
 
无痴 的头像
热心会员
 
资 料:
注册日期: Apr 2006
帖子: 1,062 声望值: 5
精华: 0,解答: 1
#71 旧 2016-01-09, 21:49:22 默认
无痴 当前离线  

真心好用,用来剪切以及调整限制都很好用。
正好解决了我的一个应用问题,谢谢。@midi
回复时引用此帖
sunboy
 
sunboy 的头像
热心会员
 
资 料:
注册日期: Jun 2001
帖子: 2,843 声望值: 4
精华: 2,解答: 21
#72 旧 2016-01-09, 22:39:15 默认
sunboy 当前离线  

感谢,lz新年快乐。
回复时引用此帖
浪人凡心
 
浪人凡心 的头像
高级会员
 
资 料:
注册日期: Sep 2002
帖子: 974 声望值: 3
精华: 0,解答: 1
#73 旧 2016-01-21, 14:53:08 默认
浪人凡心 当前在线  

安装了ImageMagick只是版本是6.9.3.1(没有6896版本了),配置了变量。32位系统。报错如图。
上传的图像
文件类型: png 1.png (24.5 KB, 598 次查看)
回复时引用此帖
midi
 
midi 的头像
超级会员
 
资 料:
注册日期: Oct 2001
帖子: 1,125 声望值: 3
精华: 5,解答: 35
#74 旧 2016-01-22, 09:51:29 默认
midi 当前离线  

引用:
作者: 浪人凡心 查看帖子
安装了ImageMagick只是版本是6.9.3.1(没有6896版本了),配置了变量。32位系统。报错如图。
网盘上有6896版本的存档:
JPG图片工具中文0.90 > 需要安装的支持库 > ImageMagick > ImageMagick-6.8.9-6-Q16-x86-dll.exe。文件夹里有如何设置的截图。

关于报错,应该是ImageMagick未正确设置产生的。设置完路径后,记得重启系统或运行CMD命令行,使路径生效。
我重新上传了新编译的版本,再有问题的话,请贴出来或联系我。
回复时引用此帖
qmsrobin
 
qmsrobin 的头像
热心会员
 
资 料:
注册日期: Jun 2004
帖子: 6,063 声望值: 4
精华: 0,解答: 8
#75 旧 2016-01-22, 10:57:44 默认
qmsrobin 当前离线  

mark一下,thanks.


去留无意静观那后庭花开花落;
宠辱不惊笑看那天空云卷云舒。
-------------------------------
回复时引用此帖
发表新主题 回复

标签
加深锐化, 图片处理, 图片特效

主题工具

论坛规则  发帖规则
不可以发表主题
不可以回复帖子
不可以上传附件
不可以编辑自己的帖子
论坛启用 vB 代码
版面启用 表情符号
版面启用 [IMG] 代码
版面禁用 HTML 代码


所有时间均为北京时间, 现在的时间是 15:29:50.

本论坛带宽由迅通网络提供
SSL证书由TrustAsia提供

Copyright © 2000 - 2019 ClassiClub Forum All Rights Reserved.
粤ICP备09123456号