. : : ClassiClub ForuM : : .

会员中心 论坛帮助 日历事件 标记论坛已读
返回   精品技术论坛 » 技术 » 『系统,网络,企业IT』

『系统,网络,企业IT』: Windows, iOS,Unix, 网络技术、企业信息化



发表新主题 回复
 
主题工具
benzcomp
 
benzcomp 的头像
核心会员
 
资 料:
注册日期: Jun 2000
帖子: 3,145 声望值: 3
精华: 5,解答: 5
#1 旧 2018-05-31, 18:51:39 默认 【求助】ROS访问内网问题
benzcomp 当前离线  

ROS配置了3块网卡
内网(VLAN20):集团公司网段10.0.0.0/8,我公司网段10.75.20.0/24,网关 10.75.20.1
WiFi(VLAN40):192.168.100.0/23 网关:192.1689.100.2
公网(WAN): 221.176.xxx.xxx
现在的问题是:
ROS可以访问所有地址。WiFi连接的设备,能访问公网和10.75.20.0网段,但是访问不了10.0.0.0的其他网段。10.75.20.0的上联路由不会给我做配置,如何配置NAT才能让WiFi客户端访问10.0.0.0全网段
上传的图像
文件类型: png 2018-05-31_18-48-53.png (31.9 KB, 118 次查看)


要这,再遮不住我眼,要这,再埋不了我心,
 要这众生,都明白我意,要那诸佛,都烟消云散!
回复时引用此帖
Fire
 
Fire 的头像
支柱会员
 
资 料:
注册日期: Mar 2000
帖子: 5,997 声望值: 4
精华: 0,解答: 16
#2 旧 2018-05-31, 22:15:12 默认
Fire 当前离线  

内网访问你为嘛要NAT?直接路由过去

10.75.20.1有去10.0.0.0/8的路由吗?


爱可不可以不说?
回复时引用此帖
benzcomp
 
benzcomp 的头像
核心会员
 
资 料:
注册日期: Jun 2000
帖子: 3,145 声望值: 3
精华: 5,解答: 5
#3 旧 2018-06-01, 09:17:22 默认
benzcomp 当前离线  

引用:
作者: Fire 查看帖子
内网访问你为嘛要NAT?直接路由过去

10.75.20.1有去10.0.0.0/8的路由吗?
路由在上联设备,没法配置,所以想用NAT解决
回复时引用此帖
Fire
 
Fire 的头像
支柱会员
 
资 料:
注册日期: Mar 2000
帖子: 5,997 声望值: 4
精华: 0,解答: 16
#4 旧 2018-06-01, 23:46:01 默认
Fire 当前离线  

Source NAT
Masquerade

If you want to "hide" the private LAN 192.168.0.0/24 "behind" one address 10.5.8.109 given to you by the ISP, you should use the source network address translation (masquerading) feature of the MikroTik router. The masquerading will change the source IP address and port of the packets originated from the network 192.168.0.0/24 to the address 10.5.8.109 of the router when the packet is routed through it.

To use masquerading, a source NAT rule with action 'masquerade' should be added to the firewall configuration:

/ip firewall nat add chain=srcnat action=masquerade out-interface=Public

All outgoing connections from the network 192.168.0.0/24 will have source address 10.5.8.109 of the router and source port above 1024. No access from the Internet will be possible to the Local addresses. If you want to allow connections to the server on the local network, you should use destination Network Address Translation (NAT).

Source nat to specific address

If you have multiple public IP addresses, source nat can be changed to specific IP, for example, one local subnet can be hidden behind first IP and second local subnet is masqueraded behind second IP.

/ip firewall nat
add chain=srcnat src-address=192.168.1.0/24 action=src-nat to-addresses=1.1.1.1 out-interface=Public
add chain=srcnat src-address=192.168.2.0/24 action=src-nat to-addresses=1.1.1.2 out-interface=Public



你去10.0.0.0/8应该用Masquerade,不是Source NAT.
回复时引用此帖
benzcomp
 
benzcomp 的头像
核心会员
 
资 料:
注册日期: Jun 2000
帖子: 3,145 声望值: 3
精华: 5,解答: 5
#5 旧 2018-06-02, 17:01:43 默认
benzcomp 当前离线  

引用:
作者: Fire 查看帖子
Source NAT
Masquerade

If you want to "hide" the private LAN 192.168.0.0/24 "behind" one address 10.5.8.109 given to you by the ISP, you sho......
可是用Masquerade,不通啊
回复时引用此帖
Fire
 
Fire 的头像
支柱会员
 
资 料:
注册日期: Mar 2000
帖子: 5,997 声望值: 4
精华: 0,解答: 16
#6 旧 2018-06-13, 10:20:16 默认
Fire 当前离线  

引用:
作者: benzcomp 查看帖子
可是用Masquerade,不通啊
做了NAT还要做FW放行啊
回复时引用此帖
发表新主题 回复

主题工具

论坛规则  发帖规则
不可以发表主题
不可以回复帖子
不可以上传附件
不可以编辑自己的帖子
论坛启用 vB 代码
版面启用 表情符号
版面启用 [IMG] 代码
版面禁用 HTML 代码


所有时间均为北京时间, 现在的时间是 06:01:55.

本论坛带宽由迅通网络提供
SSL证书由TrustAsia提供

Copyright © 2000 - 2018 ClassiClub Forum All Rights Reserved.
粤ICP备09123456号