精品技术论坛

精品技术论坛 (https://bbs.et8.net/bbs/index.php)
-   『软件使用』 (https://bbs.et8.net/bbs/forumdisplay.php?f=17)
-   -   【求助】Mysql安全漏洞补丁获取 (https://bbs.et8.net/bbs/showthread.php?t=1393640)

marcojia 2021-05-19 11:00:23

【求助】Mysql安全漏洞补丁获取
 
自己对Linux下的项目比较生疏,但最近被迫接了个活计,公司之前给客户做的一个数据分析平台,客户找安全公司做了漏洞扫描,扫描出我们项目的服务器上一堆Mysql、apache、openssl的漏洞,安全报告给出了Oracle网站的补丁下载路径。
之前负责人离职(很可能分手得还不大愉快),基本什么文档都没留下。我自己被赶鸭子上架之后,本来想直接升级新版的Mysql和apache、openssh。因为自己也没运维的经验,主要依赖搜索引擎,发现服务器的版本:(Linux version 3.10.0-693.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-16) (GCC) ) #1 SMP Tue Aug 22 21:09:27 UTC 2017)没找的可以对应升级的mysql8的安装包。现在数据库版本是5.7.28 Mysql Community Server(GPL)。
只好还是走第一条路,一个个补丁下下来传上去升级,然后又发现Oracle官网下补丁要验证,页面提示:need to connect your user account to a support identifier.Access and privileges are approved by an Administrator in your organization。
又把我卡住了,束手无策之下向各位坛友求教。有无方法绕过此验证获取oracle的安全补丁呢?先谢过了。

wangyu1314 2021-05-19 11:50:28

mysql 8有针对rhel centos 7的yum源,不需要你自己自行打补丁。直接用yum 安装升级即可。升级前备份好数据库。
https://dev.mysql.com/downloads/repo/yum/
https://dev.mysql.com/downloads/mysq...31&version=5.1

marcojia 2021-05-19 11:57:48

引用:

作者: wangyu1314 (文章 17766338)
mysql 8有针对rhel centos 7的yum源,不需要你自己自行打补丁。直接用yum 安装升级即可。升级前备份好数据库。https://dev.mysql.com/downloads/repo/yum/[url]https://dev.mysql.com/downloads/mysql/...

多谢wangyu1314老哥啦。

oar 2021-05-19 16:18:46

不管3721
yum update
接活来钱不叫被迫叫开心


所有时间均为北京时间, 现在的时间是 20:58:35.

本论坛带宽由迅通网络提供
SSL证书由TrustAsia提供

Copyright © 2000 - 2019 ClassiClub Forum All Rights Reserved.
粤ICP备09123456号